$re = '/k[.-]?d[.-]?f[.-]?8[.-]?2[.-]?1[.-]?0/m';
$str = 'kdf.8210, kdf-8210, kdf.82-10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);