// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)k[.-]?d[.-]?f[.-]?8[.-]?2[.-]?1[.-]?0").unwrap();
let string = "kdf.8210, kdf-8210, kdf.82-10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}