re = /k[.-]?d[.-]?f[.-]?8[.-]?2[.-]?1[.-]?0/m
str = 'kdf.8210, kdf-8210, kdf.82-10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end