package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)k[.-]?d[.-]?f[.-]?8[.-]?2[.-]?1[.-]?0`)
var str = `kdf.8210, kdf-8210, kdf.82-10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}