package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`csrftoken=([\w]+)\;`)
var str = `Set-Cookie: csrftoken=bf8748c0b1e113430d9757cf0ed06f4a; expires=Mon, 04-May-2015 20:54:08 GMT; Max-Age=31449600; Path=/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}