import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "csrftoken=([\\w]+)\\;";
final String string = "Set-Cookie: csrftoken=bf8748c0b1e113430d9757cf0ed06f4a; expires=Mon, 04-May-2015 20:54:08 GMT; Max-Age=31449600; Path=/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}