#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\#)(.*)?"
Local $sString = "# hello, world!" & @CRLF & _
"this world is sleeping" & @CRLF & _
"# world, hello!" & @CRLF & _
"! world" & @CRLF & _
"# hey, world, can you hear me?" & @CRLF & _
"$$ ..." & @CRLF & _
"one # two # три" & @CRLF & _
"# vier, fünf und sechs" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")