re = /^(\#)(.*)?/m
str = '# hello, world!
this world is sleeping
# world, hello!
! world
# hey, world, can you hear me?
$$ ...
one # two # три
# vier, fünf und sechs
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end