using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\#)(.*)?";
string input = @"# hello, world!
this world is sleeping
# world, hello!
! world
# hey, world, can you hear me?
$$ ...
one # two # три
# vier, fünf und sechs
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}