$re = '/^(\#)(.*)?/m';
$str = '# hello, world!
this world is sleeping
# world, hello!
! world
# hey, world, can you hear me?
$$ ...
one # two # три
# vier, fünf und sechs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);