package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\#)(.*)?`)
var str = `# hello, world!
this world is sleeping
# world, hello!
! world
# hey, world, can you hear me?
$$ ...
one # two # три
# vier, fà ¼nf und sechs
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}