# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[a-zA-Z][a-zA-Z0-9]{5,15}//gm;t' <<< "q1wewqaaaaaasasas"