use strict;
my $str = 'q1wewqaaaaaasasas';
my $regex = qr/^[a-zA-Z][a-zA-Z0-9]{5,15}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";