const regex = new RegExp('^[a-zA-Z][a-zA-Z0-9]{5,15}', 'gm')
const str = `q1wewqaaaaaasasas`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);