#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<![\d,.])\d{1,2}(?:[.,]\d{1,2})?(?![\d,.])"
Local $sString = ",1 " & @CRLF & _
".1" & @CRLF & _
"1 " & @CRLF & _
"10 " & @CRLF & _
"10,5 " & @CRLF & _
"333,5 " & @CRLF & _
"5,555 " & @CRLF & _
"10.50 " & @CRLF & _
"blabla 10.5 blabla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")