import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\d,.])\\d{1,2}(?:[.,]\\d{1,2})?(?![\\d,.])";
final String string = ",1 \n"
+ ".1\n"
+ "1 \n"
+ "10 \n"
+ "10,5 \n"
+ "333,5 \n"
+ "5,555 \n"
+ "10.50 \n"
+ "blabla 10.5 blabla";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}