$re = '/(?<![\d,.])\d{1,2}(?:[.,]\d{1,2})?(?![\d,.])/';
$str = ',1
.1
1
10
10,5
333,5
5,555
10.50
blabla 10.5 blabla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);