re = /(?<![\d,.])\d{1,2}(?:[.,]\d{1,2})?(?![\d,.])/
str = ',1
.1
1
10
10,5
333,5
5,555
10.50
blabla 10.5 blabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end