#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[^[:alnum:]äÄüÜöÖß0-9\-\.\s]+"
Local $sString = "Heribert-Vogt-Straße ( äöäö 1-7preg_replace("", "", $string)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")