const regex = /[^[:alnum:]äÄüÜöÖß0-9\-\.\s]+/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^[:alnum:]äÄüÜöÖß0-9\\-\\.\\s]+', 'i')
const str = `Heribert-Vogt-Straße ( äöäö 1-7preg_replace("", "", \$string)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}