$re = '/[^[:alnum:]äÄüÜöÖß0-9\-\.\s]+/i';
$str = 'Heribert-Vogt-Straße ( äöäö 1-7preg_replace("", "", $string)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);