using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^[:alnum:]äÄüÜöÖß0-9\-\.\s]+";
string input = @"Heribert-Vogt-Straße ( äöäö 1-7preg_replace("", "", $string)";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}