re = /[^[:alnum:]äÄüÜöÖß0-9\-\.\s]+/i
str = 'Heribert-Vogt-Straße ( äöäö 1-7preg_replace("", "", $string)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end