#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<li>.*\K"
Local $sString = "<li>some text" & @CRLF & _
"more text" & @CRLF & _
"" & @CRLF & _
"<li>some other text" & @CRLF & _
"any more text"
Local $sSubst = "</li>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)