using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<li>.*\K";
string substitution = @"</li>";
string input = @"<li>some text
more text
<li>some other text
any more text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}