const regex = /<li>.*\K/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<li>.*\\K', 'g')
const str = `<li>some text
more text
<li>some other text
any more text`;
const subst = `</li>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);