$re = '/<li>.*\K/';
$str = '<li>some text
more text
<li>some other text
any more text';
$subst = "</li>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;