#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(0?[0-9]|[0-9][0-9]|3[1-1].[a-zA-Z])\b"
Local $sString = "01"
Local $sSubst = "paged=2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)