re = /\b(0?[0-9]|[0-9][0-9]|3[1-1].[a-zA-Z])\b/
str = '01'
subst = 'paged=2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result