using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(0?[0-9]|[0-9][0-9]|3[1-1].[a-zA-Z])\b";
string substitution = @"paged=2";
string input = @"01";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}