use strict;
my $str = '01';
my $regex = qr/\b(0?[0-9]|[0-9][0-9]|3[1-1].[a-zA-Z])\b/p;
my $subst = 'paged=2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";