import Foundation
let pattern = #"\b(0?[0-9]|[0-9][0-9]|3[1-1].[a-zA-Z])\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"01"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"paged=2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}