# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<([a-z][a-z0-9]*)(?:[^>]*?((?:\s(?:src|href|style)=['\"][^'\"]*['\"]){0,3}))[^>]*?(\\/?)>/<$1$2$3>/ig;t' <<< "<title>Hello World</title>
<div style=\"margin:0px;\" href=\"http://www.google.com\" fadeout\"=\"\" src=\"../image.png\" >
<img src=\"abc.jpg\" alt=\"\" />
<p style=\"margin-bottom:10px;\">
The event is celebrating its 50th anniversary Kö
<a href=\"http://www.germany.travel/\" style=\"margin:0px;\">exhibition grounds in Cologne</a>.</p>
<p style=\"padding:0px;\"></p>
<p style=\"color:black;\"><strong>A festival for art lovers</strong></p>
</div>"