import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([a-z][a-z0-9]*)(?:[^>]*?((?:\\s(?:src|href|style)=['\\\"][^'\\\"]*['\\\"]){0,3}))[^>]*?(\\/?)>";
final String string = "<title>Hello World</title>\n"
+ "<div style=\"margin:0px;\" href=\"http://www.google.com\" fadeout\"=\"\" src=\"../image.png\" >\n"
+ "<img src=\"abc.jpg\" alt=\"\" />\n"
+ "<p style=\"margin-bottom:10px;\">\n"
+ "The event is celebrating its 50th anniversary Kö \n"
+ "<a href=\"http://www.germany.travel/\" style=\"margin:0px;\">exhibition grounds in Cologne</a>.</p>\n"
+ "<p style=\"padding:0px;\"></p>\n"
+ "<p style=\"color:black;\"><strong>A festival for art lovers</strong></p>\n"
+ "</div>";
final String subst = "<$1$2$3>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}