import re
regex = re.compile(r"<([a-z][a-z0-9]*)(?:[^>]*?((?:\s(?:src|href|style)=['\"][^'\"]*['\"]){0,3}))[^>]*?(\/?)>", flags=re.IGNORECASE)
test_str = ("<title>Hello World</title>\n"
"<div style=\"margin:0px;\" href=\"http://www.google.com\" fadeout\"=\"\" src=\"../image.png\" >\n"
"<img src=\"abc.jpg\" alt=\"\" />\n"
"<p style=\"margin-bottom:10px;\">\n"
"The event is celebrating its 50th anniversary Kö \n"
"<a href=\"http://www.germany.travel/\" style=\"margin:0px;\">exhibition grounds in Cologne</a>.</p>\n"
"<p style=\"padding:0px;\"></p>\n"
"<p style=\"color:black;\"><strong>A festival for art lovers</strong></p>\n"
"</div>")
subst = "<$1$2$3>"
result = regex.sub(subst, test_str)
if result:
print(result)