#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\/blog\/((?!page)[^\/]+)\/?$"
Local $sString = "/blog/post-name-without-end-slash" & @CRLF & _
"/blog/post-name-with-slash/" & @CRLF & _
"/blog/page/2/" & @CRLF & _
"/blog/page/3/" & @CRLF & _
"/blog/"
Local $sSubst = "/$1/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)