use strict;
my $str = '/blog/post-name-without-end-slash
/blog/post-name-with-slash/
/blog/page/2/
/blog/page/3/
/blog/';
my $regex = qr/^\/blog\/((?!page)[^\/]+)\/?$/mp;
my $subst = '/$1/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";