re = /^\/blog\/((?!page)[^\/]+)\/?$/m
str = '/blog/post-name-without-end-slash
/blog/post-name-with-slash/
/blog/page/2/
/blog/page/3/
/blog/'
subst = '/$1/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result