# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\/blog\/((?!page)[^\/]+)\/?$"
test_str = ("/blog/post-name-without-end-slash\n"
"/blog/post-name-with-slash/\n"
"/blog/page/2/\n"
"/blog/page/3/\n"
"/blog/")
subst = "/$1/"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.