using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/blog\/((?!page)[^\/]+)\/?$";
string substitution = @"/$1/";
string input = @"/blog/post-name-without-end-slash
/blog/post-name-with-slash/
/blog/page/2/
/blog/page/3/
/blog/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}