#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\".*?joe.*?\"$"
Local $sString = ""123joe456"" & @CRLF & _
"123joe456" & @CRLF & _
""joe"" & @CRLF & _
""1joe"" & @CRLF & _
""joe2"" & @CRLF & _
""jo2e"" & @CRLF & _
"blabla"blajoebla"blabla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")