import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\\".*?joe.*?\\\"$";
final String string = "\"123joe456\"\n"
+ "123joe456\n"
+ "\"joe\"\n"
+ "\"1joe\"\n"
+ "\"joe2\"\n"
+ "\"jo2e\"\n"
+ "blabla\"blajoebla\"blabla";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}