re = /^\".*?joe.*?\"$/m
str = '"123joe456"
123joe456
"joe"
"1joe"
"joe2"
"jo2e"
blabla"blajoebla"blabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end