$re = '/^\".*?joe.*?\"$/m';
$str = '"123joe456"
123joe456
"joe"
"1joe"
"joe2"
"jo2e"
blabla"blajoebla"blabla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);