// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^\".*?joe.*?\"$"#).unwrap();
let string = "\"123joe456\"
123joe456
\"joe\"
\"1joe\"
\"joe2\"
\"jo2e\"
blabla\"blajoebla\"blabla";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}