use strict;
my $str = '"Motor des regionalen Neuen Forums"';
my $regex = qr/"([^"]+)"/p;
my $subst = '\\q{\\1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";