# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w{2}(\s|$)/*$1/gu;t' <<< "Иванов Иван Иванович"