$re = '/\w{2}(\s|$)/u';
$str = 'Иванов Иван Иванович';
$subst = "*$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;