package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w{2}(\s|$)`)
var str = `Иванов Иван Иванович`
var substitution = "*$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}