const regex = /\w{2}(\s|$)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w{2}(\\s|$)', 'gu')
const str = `Иванов Иван Иванович`;
const subst = `*$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);